medium5.5
CVE-2023-40032
libvips is a demand-driven, horizontally threaded image processing library.
Impact
libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Fedoraproject | Fedora | Version 39 |
| Libvips | Libvips | from 8.12.0 before 8.14.4 |
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/libvips/libvips/commit/e091d65835966ef56d53a4105a7362cafdb1582b
- https://github.com/libvips/libvips/pull/3604
- https://github.com/libvips/libvips/security/advisories/GHSA-33qp-9pq7-9584
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YU2FFC47X2XDEGEHEWAGLU5L3R6FEYD2/
- https://github.com/libvips/libvips/commit/e091d65835966ef56d53a4105a7362cafdb1582b
- https://github.com/libvips/libvips/pull/3604
- https://github.com/libvips/libvips/security/advisories/GHSA-33qp-9pq7-9584
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YU2FFC47X2XDEGEHEWAGLU5L3R6FEYD2/