NetSight
medium6.7

CVE-2023-40312

OpenNMS vulnerable to Cross-site Scripting

Impact

Multiple reflected XSS were found on different JSP files with unsanitized parameters in OpenNMS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms that an attacker can modify to craft a malicious XSS payload. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Jordi Miralles Comins for reporting this issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.opennms:opennms-webapp>= 31.0.8, < 32.0.232.0.2

Affected products

VendorProductAffected versions
OpennmsHorizon
from 31.0.8 before 32.0.2
OpennmsMeridian
before 2020.1.38
from 2022.1.0 before 2022.1.19
from 2023.1.0 before 2023.1.6

Weakness classification

References