NetSight
high7.1

CVE-2023-40313

OpenNMS vulnerable to remote code execution

Impact

A BeanShell interpreter in remote server mode runs in OpenNMS Horizon versions earlier than 32.0.2 and in related Meridian versions which could allow arbitrary remote Java code execution. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.opennms:opennms-base-assembly< 32.0.232.0.2

Affected products

VendorProductAffected versions
OpennmsHorizon
before 32.0.2
OpennmsMeridian
before 2020.1.38
from 2021.1.0 before 2021.1.30
from 2022.1.0 before 2022.1.19
from 2023.1.0 before 2023.1.6

Weakness classification

References