NetSight
medium5.3

CVE-2023-40315

OpenNMS privilege escalation vulnerability

Impact

In OpenNMS Horizon 31.0.8 and versions earlier than 32.0.2 and related Meridian versions, any user that has the ROLE_FILESYSTEM_EDITOR can easily escalate their privileges to ROLE_ADMIN or any other role. The solution is to upgrade to Meridian 2023.1.5 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.opennms:opennms-webapp-rest>= 31.0.8, < 32.0.232.0.2

Affected products

VendorProductAffected versions
OpennmsHorizon
from 31.0.8 before 32.0.2
OpennmsMeridian
from 2023.0.0 before 2023.1.5

Weakness classification

References