medium6.5
CVE-2023-40579
OpenFGA Authorization Bypass
Impact
## Overview Some end users of OpenFGA v1.3.0 or earlier are vulnerable to authorization bypass when calling the ListObjects API. This means that the API sometimes returns more objects than it should. ## Am I Affected? The vulnerability affects customers using ListObjects with specific models. The affected models contain expressions of type `rel1 from type1`. ## Fix Update to v1.3.1. ## Backward Compatibility This update is backward compatible.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/openfga/openfga | < 1.3.1 | 1.3.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Openfga | Openfga | before 1.3.1 |