NetSight
high7.8

CVE-2023-41267

Apache HDFS Provider error message suggested

Impact

In the Apache Airflow HDFS Provider, versions prior to 4.1.1, a documentation info pointed users to an install incorrect pip package. As this package name was unclaimed, in theory, an attacker could claim this package and provide code that would be executed when this package was installed. The Airflow team has since taken ownership of the package (neutralizing the risk), and fixed the doc strings in version 4.1.1

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow-providers-apache-hdfs< 4.1.14.1.1

Affected products

VendorProductAffected versions
ApacheAirflow Hdfs Provider
before 4.1.1

Weakness classification

References