NetSight
high7.5

CVE-2023-41890

Sustainsys.Saml2 Insufficient Identity Provider Issuer Validation

Impact

### Impact When a response is processed, the issuer of the Identity Provider is not sufficiently validated. This could allow a malicious identity provider to craft a Saml2 response that is processed as if issued by another identity provider. It is also possible for a malicious end user to cause stored state intended for one identity provider to be used when processing the response from another provider. An application is impacted if they rely on any of these features in their authentication/authorization logic: * the issuer of the generated identity and claims * items in the stored request state (AuthenticationProperties) ### Patches Patched in version 2.9.2 and 1.0.3. All previous versions are vulnerable. ### Workarounds The `AcsCommandResultCreated` notification can be used to add the validation required if an upgrade to patched packages is not possible. ### References The patch is linked to https://github.com/Sustainsys/Saml2/issues/712 and https://github.com/Sustainsys/Saml2/issues/713

Affected packages

EcosystemPackageAffectedFixed in
nugetSustainsys.Saml2< 1.0.31.0.3
nugetKentor.AuthServices<= 0.23.0none recorded

Affected products

VendorProductAffected versions
SustainsysSaml2
before 1.0.3
from 2.0.0 before 2.9.2

Weakness classification

References