high6.5
CVE-2023-41916
Apache Linkis DataSource allows arbitrary file reading
Impact
In Apache Linkis = 1.4.0, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in the DataSource Manager Module will trigger arbitrary file reading. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis = 1.4.0 will be affected. We recommend users upgrade the version of Linkis to version 1.6.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.linkis:linkis-datasource | >= 1.4.0, < 1.6.0 | 1.6.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Linkis | from 1.4.0 before 1.6.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/dxkpwyoxy1jpdwlpqp15zvo0jxn4v729
- http://www.openwall.com/lists/oss-security/2024/07/13/4
- https://github.com/advisories/GHSA-f22j-9j59-33j4
- https://nvd.nist.gov/vuln/detail/CVE-2023-41916
- https://linkis.apache.org/download/release-notes-1.6.0