medium4.3
CVE-2023-42501
Apache Superset has Incorrect Default Permissions
Impact
Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run `superset init` to reconstruct the Gamma role or remove `can_read` permission from the mentioned resources.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | apache-superset | < 2.1.2 | 2.1.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Superset | before 2.1.1 |