critical9.0
CVE-2023-42628
Liferay Portal and Liferay DXP Vulnerable to XSS in the Wiki Widget
Impact
Stored cross-site scripting (XSS) vulnerability in the Wiki widget in Liferay Wiki Web before 7.0.95 from Liferay Portal (7.1.0 through 7.4.3.87), and Liferay DXP 7.0 fix pack 83 through 102, 7.1 fix pack 28 and earlier, 7.2 fix pack 20 and earlier, 7.3 update 33 and earlier, and 7.4 before update 88 allows remote attackers to inject arbitrary web script or HTML into a parent wiki page via a crafted payload injected into a wiki page's ‘Content’ text field.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | com.liferay:com.liferay.wiki.web | < 7.0.95 | 7.0.95 |
| maven | com.liferay.portal:release.dxp.bom | >= 7.0.10.fp83, <= 7.0.10.fp102 | none recorded |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Liferay | Digital Experience Platform | Versions 7.0, 7.1, 7.2, 7.3, 7.4 |
| Liferay | Liferay Portal | from 7.1.0 before 7.4.3.88 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://liferay.dev/portal/security/known-vulnerabilities/-/asset_publisher/jekt/content/cve-2023-42628
- https://www.pentagrid.ch/en/blog/stored-cross-site-scripting-vulnerabilities-in-liferay-portal/
- https://github.com/advisories/GHSA-hv45-r2f5-fmhj
- https://nvd.nist.gov/vuln/detail/CVE-2023-42628
- https://www.pentagrid.ch/en/blog/stored-cross-site-scripting-vulnerabilities-in-liferay-portal