NetSight
medium6.5

CVE-2023-42663

Apache Airflow vulnerable to sensitive information exposure

Impact

Apache Airflow, versions before 2.7.2, has a vulnerability that allows an authorized user with access to read specific DAGs _only_ to read information about task instances in other DAGs. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow>= 0, < 2.7.22.7.2

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.7.2

Weakness classification

References