NetSight
medium6.5

CVE-2023-42780

Apache Airflow vulnerable to sensitive information exposure when users list warnings for all DAGs

Impact

Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permission to see those DAGs. It would reveal the dag_ids and the stack-traces of import errors for those DAGs with import errors. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow< 2.7.22.7.2

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.7.2

Weakness classification

References