NetSight
high6.5

CVE-2023-42781

Apache Airflow vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

Impact

Apache Airflow, versions before 2.7.3, has a vulnerability that allows an authorized user who has access to read specific DAGs only, to read information about task instances in other DAGs.  This is a different issue than CVE-2023-42663 but leading to similar outcome. Users of Apache Airflow are advised to upgrade to version 2.7.3 or newer to mitigate the risk associated with this vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow< 2.7.32.7.3

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.7.3

Weakness classification

References