NetSight
medium6.5

CVE-2023-42792

Apache Airflow vulnerable to privilege escalation

Impact

Apache Airflow, in versions prior to 2.7.2, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't. Users of Apache Airflow are strongly advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow< 2.7.22.7.2

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.7.2

Weakness classification

References