critical9.8
CVE-2023-42810
systeminformation SSID Command Injection Vulnerability
Impact
### Impact SSID Command Injection Vulnerability ### Patches Problem was fixed with a parameter check. Please upgrade to version >= 5.21.7, Version 4 was not affected ### Workarounds If you cannot upgrade, be sure to check or sanitize parameter strings that are passed to wifiConnections(), wifiNetworks() (string only) ### References See also https://systeminformation.io/security.html
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | systeminformation | >= 5.0.0, < 5.21.7 | 5.21.7 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Systeminformation | Systeminformation | from 5.0.0 before 5.21.7 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/sebhildebrandt/systeminformation/commit/7972565812ccb2a610a22911c54c3446f4171392
- https://github.com/sebhildebrandt/systeminformation/security/advisories/GHSA-gx6r-qc2v-3p3v
- https://systeminformation.io/security.html
- https://github.com/advisories/GHSA-gx6r-qc2v-3p3v
- https://nvd.nist.gov/vuln/detail/CVE-2023-42810