NetSight
critical9.8

CVE-2023-43668

Authorization Bypass in Apache InLong

Impact

Authorization Bypass Through User-Controlled Key vulnerability in Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.8.0,  some sensitive params checks will be bypassed, like "autoDeserizalize","allowLoadLocalInfile".... .   Users are advised to upgrade to Apache InLong's 1.9.0 or cherry-pick [1] to solve it. [1]  https://github.com/apache/inlong/pull/8604

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:manager-pojo>= 1.4.0, < 1.9.01.9.0

Affected products

VendorProductAffected versions
ApacheInlong
from 1.4.0 through 1.8.0

Weakness classification

References