NetSight
medium4.3

CVE-2023-43701

Apache Superset Cross-site Scripting vulnerability

Impact

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache Superset versions prior to 2.1.2.  Users are recommended to upgrade to version 2.1.2, which fixes this issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-superset< 2.1.22.1.2

Affected products

VendorProductAffected versions
ApacheSuperset
before 2.1.2

Weakness classification

References