medium6.1Known exploited
CVE-2023-43770
Roundcube Webmail Persistent Cross-Site Scripting (XSS) Vulnerability
Exploited in the wild
This vulnerability is on a Known Exploited Vulnerabilities catalogue, added 2024-02-12. Federal due date: 2024-03-04.
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Impact
Roundcube before 1.4.14, 1.5.x before 1.5.4, and 1.6.x before 1.6.3 allows XSS via text/plain e-mail messages with crafted links because of program/lib/Roundcube/rcube_string_replacer.php behavior.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Roundcube | Webmail | before 1.4.14 from 1.5.0 before 1.5.4 from 1.6.0 before 1.6.3 |
| Debian | Debian Linux | Version 10.0 |
Weakness classification
References
- NVD record
- CVE.org record
- CISA KEV catalog
- https://github.com/roundcube/roundcubemail/commit/e92ec206a886461245e1672d8530cc93c618a49b
- https://lists.debian.org/debian-lts-announce/2023/09/msg00024.html
- https://roundcube.net/news/2023/09/15/security-update-1.6.3-released
- https://github.com/roundcube/roundcubemail/commit/e92ec206a886461245e1672d8530cc93c618a49b
- https://lists.debian.org/debian-lts-announce/2023/09/msg00024.html
- https://roundcube.net/news/2023/09/15/security-update-1.6.3-released
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-43770