NetSight
high7.0

CVE-2023-4504

Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflo…

Impact

Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.

Affected products

VendorProductAffected versions
OpenprintingCups
before 2.4.7
OpenprintingLibppd
Version 2.0
FedoraprojectFedora
Versions 37, 38, 39
DebianDebian Linux
Version 10.0

Weakness classification

References