NetSight
medium5.3

CVE-2023-45648

Apache Tomcat Improper Input Validation vulnerability

Impact

Improper Input Validation vulnerability in Apache Tomcat. Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0 through 8.5.93 did not correctly parse HTTP trailer headers. A specially crafted, invalid trailer header could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat>= 11.0.0-M1, < 11.0.0-M1211.0.0-M12
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 11.0.0-M1, < 11.0.0-M1211.0.0-M12
mavenorg.apache.tomcat:tomcat-coyote>= 11.0.0-M1, < 11.0.0-M1211.0.0-M12

Affected products

VendorProductAffected versions
ApacheTomcat
from 8.5.0 before 8.5.94
from 9.0.1 before 9.0.81
from 10.1.1 before 10.1.14
Versions 9.0.0, 10.1.0, 11.0.0
DebianDebian Linux
Versions 10.0, 11.0, 12.0

Weakness classification

References