medium6.4
CVE-2023-4599
The Email Encoder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'eeb_mailto' shortcode in versions up to, and including, 2.1.8 due …
Impact
The Email Encoder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'eeb_mailto' shortcode in versions up to, and including, 2.1.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A partial patch was issued in version 2.1.8. The vulnerability was fully patched in 2.1.9.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Wp-Webhooks | Email Encoder | through 2.1.7 |
Weakness classification
References
- NVD record
- CVE.org record
- https://plugins.trac.wordpress.org/browser/email-encoder-bundle/tags/2.1.7/core/includes/classes/class-email-encoder-bundle-run.php#L529
- https://plugins.trac.wordpress.org/changeset/2958823/email-encoder-bundle#file60
- https://plugins.trac.wordpress.org/changeset/2994384/email-encoder-bundle/trunk?contextall=1&old=2958823&old_path=%2Femail-encoder-bundle%2Ftrunk#file0
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e90f04e4-eb4c-4822-89c6-79f553987c37?source=cve
- https://plugins.trac.wordpress.org/browser/email-encoder-bundle/tags/2.1.7/core/includes/classes/class-email-encoder-bundle-run.php#L529
- https://plugins.trac.wordpress.org/changeset/2958823/email-encoder-bundle#file60
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e90f04e4-eb4c-4822-89c6-79f553987c37?source=cve