medium4.9
CVE-2023-46118
RabbitMQ vulnerable to Denial of Service by publishing large messages over the HTTP API
Impact
RabbitMQ is a multi-protocol messaging and streaming broker. HTTP API did not enforce an HTTP request body limit, making it vulnerable for denial of service (DoS) attacks with very large messages. An authenticated user with sufficient credentials can publish a very large messages over the HTTP API and cause target node to be terminated by an "out-of-memory killer"-like mechanism. This vulnerability has been patched in versions 3.11.24 and 3.12.7.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| erlang | rabbit_common | >= 3.12.0, < 3.12.7 | 3.12.7 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Vmware | Rabbitmq | before 3.11.24 from 3.12.0 before 3.12.7 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-w6cq-9cf4-gqpg
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-w6cq-9cf4-gqpg
- https://nvd.nist.gov/vuln/detail/CVE-2023-46118
- https://lists.debian.org/debian-lts-announce/2023/12/msg00009.html
- https://www.debian.org/security/2023/dsa-5571