high7.5
CVE-2023-46215
Apache Airflow Celery provider Insertion of Sensitive Information into Log File vulnerability
Impact
Insertion of Sensitive Information into Log File vulnerability in Apache Airflow Celery provider, Apache Airflow. Sensitive information logged as clear text when rediss, amqp, rpc protocols are used as Celery result backend Note: the vulnerability is about the information exposed in the logs not about accessing the logs. This issue affects Apache Airflow Celery provider: from 3.3.0 through 3.4.0; Apache Airflow: from 1.10.0 through 2.6.3. Users are recommended to upgrade Airflow Celery provider to version 3.4.1 and Apache Airlfow to version 2.7.0 which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | apache-airflow-providers-celery | >= 3.3.0, < 3.4.1 | 3.4.1 |
| pip | apache-airflow | >= 1.10.0, < 2.7.0 | 2.7.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Airflow | from 1.10.0 before 2.7.0 |
| Apache | Airflow Celery Provider | from 3.3.0 through 3.4.0 |