high7.5
CVE-2023-46227
Apache InLong Deserialization of Untrusted Data Vulnerability
Impact
Deserialization of Untrusted Data Vulnerability in Apache Software Foundation Apache InLong. This issue affects Apache InLong: from 1.4.0 through 1.8.0, the attacker can use \t to bypass. Users are advised to upgrade to Apache InLong's 1.9.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/8814
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.inlong:manager-common | >= 1.4.0, < 1.9.0 | 1.9.0 |
| maven | org.apache.inlong:manager-pojo | >= 1.4.0, < 1.9.0 | 1.9.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Inlong | from 1.4.0 before 1.9.0 |