NetSight
high7.5

CVE-2023-46240

CodeIgniter4 vulnerable to information disclosure when detailed error report is displayed in production environment

Impact

### Impact If an error or exception occurs in CodeIgniter4 v4.4.2 and earlier, a detailed error report is displayed even if in the production environment. As a result, confidential information may be leaked. ### Patches Upgrade to v4.4.3 or later. See [upgrading guide](https://codeigniter4.github.io/userguide/installation/upgrade_443.html). ### Workarounds Replace `ini_set('display_errors', '0')` with `ini_set('display_errors', 'Off')` in `app/Config/Boot/production.php`. ### For more information If you have any questions or comments about this advisory: * Open an issue in [codeigniter4/CodeIgniter4](https://github.com/codeigniter4/CodeIgniter4/issues) * Email us at [SECURITY.md](https://github.com/codeigniter4/CodeIgniter4/blob/develop/SECURITY.md)

Affected packages

EcosystemPackageAffectedFixed in
composercodeigniter4/framework<= 4.4.24.4.3

Affected products

VendorProductAffected versions
CodeigniterCodeigniter
before 4.4.3

Weakness classification

References