NetSight
high7.5

CVE-2023-46589

Apache Tomcat Improper Input Validation vulnerability

Impact

Improper Input Validation vulnerability in Apache Tomcat. Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82, and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat-catalina>= 11.0.0-M1, < 11.0.0-M1111.0.0-M11
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 11.0.0-M1, < 11.0.0-M1111.0.0-M11
mavenorg.apache.tomcat:tomcat-coyote>= 11.0.0-M1, < 11.0.0-M1111.0.0-M11

Affected products

VendorProductAffected versions
ApacheTomcat
from 8.5.0 before 8.5.96
from 9.0.0 before 9.0.83
from 10.1.0 before 10.1.16
Version 11.0.0

Weakness classification

References