medium6.5
CVE-2023-46749
Apache Shiro vulnerable to path traversal
Impact
Apache Shiro before 1.130 or 2.0.0-alpha-4, may be susceptible to a path traversal attack that results in an authentication bypass when used together with path rewriting Mitigation: Update to Apache Shiro 1.13.0+ or 2.0.0-alpha-4+, or ensure `blockSemicolon` is enabled (this is the default).
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.shiro:shiro-core | < 1.13.0 | 1.13.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Shiro | before 1.13.0 Version 2.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/mdv7ftz7k4488rzloxo2fb0p9shnp9wm
- https://security.netapp.com/advisory/ntap-20241108-0002/
- https://github.com/advisories/GHSA-jc7h-c423-mpjc
- https://nvd.nist.gov/vuln/detail/CVE-2023-46749
- https://security.netapp.com/advisory/ntap-20241108-0002