NetSight
medium4.3

CVE-2023-47037

Apache Airflow allows authenticated and DAG-view authorized users to modify some DAG run detail values when submitting notes

Impact

Apache Airflow, versions before 2.7.3, is affected by a vulnerability that allows authenticated and DAG-view authorized Users to modify some DAG run detail values when submitting notes. This could have them alter details such as configuration parameters, start date, etc.  Users should upgrade to version 2.7.3 or later which has removed the vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow< 2.7.32.7.3

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.7.3

Weakness classification

References