medium5.0
CVE-2023-48631
@adobe/css-tools Improper Input Validation and Inefficient Regular Expression Complexity
Impact
### Impact @adobe/css-tools version 4.3.1 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS. ### Patches The issue has been resolved in 4.3.2. ### Workarounds None ### References N/A
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | @adobe/css-tools | < 4.3.2 | 4.3.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Adobe | Css-Tools | before 4.3.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/adobe/css-tools/security/advisories/GHSA-prr3-c3m5-p7q2
- https://github.com/advisories/GHSA-prr3-c3m5-p7q2
- https://github.com/adobe/css-tools/issues/211
- https://github.com/adobe/css-tools/pull/249
- https://github.com/adobe/css-tools/commit/472bef91bde9caab305f3f36231ad0c253581b43
- https://nvd.nist.gov/vuln/detail/CVE-2023-48631