high7.9
CVE-2023-49145
Improper Neutralization of Input in Advanced User Interface for Jolt
Impact
Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is vulnerable to DOM-based cross-site scripting. If an authenticated user, who is authorized to configure a JoltTransformJSON Processor, visits a crafted URL, then arbitrary JavaScript code can be executed within the session context of the authenticated user. Upgrading to Apache NiFi 1.24.0 or 2.0.0-M1 is the recommended mitigation.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.nifi:nifi-jolt-transform-json-ui | < 1.24.0 | 1.24.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Nifi | from 0.7.0 before 1.24.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2023/11/27/5
- https://lists.apache.org/thread/j8rd0qsvgoj0khqck5f49jfbp0fm8r1o
- https://nifi.apache.org/security.html#CVE-2023-49145
- https://github.com/advisories/GHSA-68pr-6fjc-wmgm
- https://nvd.nist.gov/vuln/detail/CVE-2023-49145
- https://github.com/apache/nifi/pull/8060
- https://github.com/apache/nifi/commit/50efc55df6bb00ea15adcc2459d5cc82d128857f
- https://issues.apache.org/jira/browse/NIFI-12403