high8.8
CVE-2023-49213
The API endpoints in Ironman PowerShell Universal 3.0.0 through 4.2.0 allow remote attackers to execute arbitrary commands via crafted HTTP requests if a param…
Impact
The API endpoints in Ironman PowerShell Universal 3.0.0 through 4.2.0 allow remote attackers to execute arbitrary commands via crafted HTTP requests if a param block is used, due to invalid sanitization of input strings. The fixed versions are 3.10.2, 4.1.10, and 4.2.1.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Ironmansoftware | Powershell Universal | from 3.0.0 before 3.10.2 from 4.1.0 before 4.1.10 Version 4.2.0 |