NetSight
high8.8

CVE-2023-49299

Apache DolphinScheduler: Arbitrary js execute as root for authenticated users

Impact

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server.This issue affects Apache DolphinScheduler: until 3.1.9. Users are recommended to upgrade to version 3.1.9, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.dolphinscheduler:dolphinscheduler-master< 3.1.93.1.9

Affected products

VendorProductAffected versions
ApacheDolphinscheduler
before 3.1.9

Weakness classification

References