NetSight
high8.8

CVE-2023-49566

Apache Linkis DataSource's JDBC Datasource Module with DB2 has JNDI Injection vulnerability

Impact

In Apache Linkis <=1.5.0, due to the lack of effective filteringof parameters, an attacker configuring malicious `db2` parameters in the DataSource Manager Module will result in jndi injection. Therefore, the parameters in the DB2 URL should be blacklisted.  This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis <=1.5.0 will be affected. We recommend users upgrade the version of Linkis to version 1.6.0.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.linkis:linkis-datasource< 1.6.01.6.0

Affected products

VendorProductAffected versions
ApacheLinkis
from 1.4.0 before 1.6.0

Weakness classification

References