NetSight
high7.7

CVE-2023-49734

Apache Superset incorrect write permissions vulnerability

Impact

An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the owners of the charts allowing him to incorrectly have write permissions to these charts.This issue affects Apache Superset: before 2.1.3, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2 or 2.1.3, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-superset< 2.1.32.1.3

Affected products

VendorProductAffected versions
ApacheSuperset
before 2.1.2
from 3.0.0 before 3.0.2

Weakness classification

References