medium6.5
CVE-2023-49736
Apache Superset SQL injection vulnerability
Impact
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.3, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 2.1.3 or 3.0.2, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | apache-superset | < 2.1.3 | 2.1.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Superset | before 2.1.2 from 3.0.0 before 3.0.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2023/12/19/2
- https://lists.apache.org/thread/1kf481bgs3451qcz6hfhobs7xvhp8n1p
- https://github.com/advisories/GHSA-jfxj-xf67-x723
- https://nvd.nist.gov/vuln/detail/CVE-2023-49736
- https://github.com/apache/superset/pull/25779
- https://github.com/apache/superset/commit/1d403dab9822a8cee6108669c53e53fad881c751
- https://github.com/apache/superset/commit/34101594e284ab3acce692f41aff7759ccb4bf1d