NetSight
medium6.5

CVE-2023-49920

Apache Airflow Cross-Site Request Forgery vulnerability

Impact

Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow>= 2.7.0, < 2.8.02.8.0

Affected products

VendorProductAffected versions
ApacheAirflow
from 2.7.0 through 2.7.3

Weakness classification

References