NetSight
critical9.8

CVE-2023-50164

Apache Struts vulnerable to path traversal

Impact

An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution. Users are recommended to upgrade to versions Struts 2.5.33 or Struts 6.3.0.2 or greater to fix this issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.struts:struts2-core>= 6.0.0, < 6.3.0.26.3.0.2

Affected products

VendorProductAffected versions
ApacheStruts
from 2.0.0 before 2.5.33
from 6.0.0 before 6.3.0.2

Weakness classification

References