high8.8
CVE-2023-50379
Apache Ambari: authenticated users could perform command injection to perform RCE
Impact
Malicious code injection in Apache Ambari in prior to 2.7.8. Users are recommended to upgrade to version 2.7.8, which fixes this issue. Impact: A Cluster Operator can manipulate the request by adding a malicious code injection and gain a root over the cluster main host.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.ambari.contrib.views:ambari-contrib-views | >= 2.7.0, < 2.7.8 | 2.7.8 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Ambari | before 2.7.8 |