NetSight
critical9.1

CVE-2023-50422

Improper JWT Signature Validation in SAP Security Services Library

Impact

### Impact SAP BTP Security Services Integration Library ([Java] cloud-security-services-integration-library) allows under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application. ### Patches Upgrade to patched version >= 2.17.0 or >= 3.3.0 We always recommend to upgrade to the latest released version. ### Workarounds No workarounds ### References https://www.cve.org/CVERecord?id=CVE-2023-50422

Affected packages

EcosystemPackageAffectedFixed in
mavencom.sap.cloud.security:java-security< 2.17.02.17.0
mavencom.sap.cloud.security:spring-security< 2.17.02.17.0
mavencom.sap.cloud.security.xsuaa:spring-xsuaa< 2.17.02.17.0

Affected products

VendorProductAffected versions
SapCloud-Security-Services-Integration-Library
before 2.17.0
from 3.0.0 before 3.3.0

Weakness classification

References