NetSight
critical9.1

CVE-2023-50423

Improper Privilege Management in sap-xssec

Impact

### Impact SAP BTP Security Services Integration Library ([Python] sap-xssec) allows under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application. ### Patches Upgrade to patched version >= 4.1.0 We always recommend to upgrade to the latest released version. ### Workarounds No workarounds ### References https://www.cve.org/CVERecord?id=CVE-2023-50423

Affected packages

EcosystemPackageAffectedFixed in
pipsap-xssec< 4.1.04.1.0

Affected products

VendorProductAffected versions
SapSap-Xssec
before 4.1.0

Weakness classification

References