NetSight
medium6.8

CVE-2023-50714

yiisoft/yii2-authclient's Oauth2 PKCE implementation is vulnerable

Impact

### Impact _What kind of vulnerability is it? Who is impacted?_ Original Report: > The Oauth2 PKCE implementation is vulnerable in 2 ways: > 1. The `authCodeVerifier` should be removed after usage (similar to 'authState') > 2. There is a risk for a "downgrade attack" if PKCE is being relied on for CSRF protection. ### Patches _Has the problem been patched? What versions should users upgrade to?_ 2.2.15 ### Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ not known yet. ### References _Are there any links users can visit to find out more?_

Affected packages

EcosystemPackageAffectedFixed in
composeryiisoft/yii2-authclient< 2.2.152.2.15

Affected products

VendorProductAffected versions
YiiframeworkYii2-Authclient
before 2.2.15

Weakness classification

References