NetSight
high7.5

CVE-2023-50730

Grackle has StackOverflowError in GraphQL query processing

Impact

### Impact Prior to this fix, the GraphQL query parsing was vulnerable to `StackOverflowError`s. The possibility of small queries resulting in stack overflow is a potential denial of service vulnerability. This potentially affects all applications using Grackle which have untrusted users. > [!CAUTION] > **No specific knowledge of an application's GraphQL schema would be required to construct a pathological query.** ### Patches The stack overflow issues have been resolved in the v0.18.0 release of Grackle. ### Workarounds Users could interpose a sanitizing layer in between untrusted input and Grackle query processing.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.typelevel:grackle-core_2.13< 0.18.00.18.0
mavenorg.typelevel:grackle-core_3< 0.18.00.18.0
mavenorg.typelevel:grackle-core_sjs1_2.13< 0.18.00.18.0
mavenorg.typelevel:grackle-core_sjs1_3< 0.18.00.18.0
mavenorg.typelevel:grackle-core_native0.4_2.13< 0.18.00.18.0
mavenorg.typelevel:grackle-core_native0.4_3< 0.18.00.18.0
mavenedu.gemini:gsp-graphql-core_2.13<= 0.14.0none recorded
mavenedu.gemini:gsp-graphql-core_3<= 0.14.0none recorded
mavenedu.gemini:gsp-graphql-core_sjs1_2.13<= 0.14.0none recorded
mavenedu.gemini:gsp-graphql-core_sjs1_3<= 0.14.0none recorded
mavenedu.gemini:gsp-graphql-core_native0.4_2.13<= 0.14.0none recorded
mavenedu.gemini:gsp-graphql-core_native0.4_3<= 0.14.0none recorded

Affected products

VendorProductAffected versions
TypelevelGrackle
before 0.18.0

Weakness classification

References