NetSight
medium6.5

CVE-2023-50783

Apache Airflow Improper Access Control vulnerability

Impact

Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow< 2.8.02.8.0

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.8.0

Weakness classification

References