NetSight
high6.5

CVE-2023-50944

Apache Airflow: Bypass permission verification to read code of other dags

Impact

Apache Airflow, versions before 2.8.1, have a vulnerability that allows an authenticated user to access the source code of a DAG to which they don't have access. This vulnerability is considered low since it requires an authenticated user to exploit it. Users are recommended to upgrade to version 2.8.1, which fixes this issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow>= 0, < 2.8.1rc12.8.1rc1

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.8.1

Weakness classification

References