low2.7
CVE-2023-51380
An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed issue comments to be read with an improperly scoped token.
Impact
An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed issue comments to be read with an improperly scoped token. This vulnerability affected all versions of GitHub Enterprise Server since 3.7 and was fixed in version 3.7.19, 3.8.12, 3.9.7, 3.10.4, and 3.11.1.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Github | Enterprise Server | from 3.7.0 before 3.7.19 from 3.8.0 before 3.8.12 from 3.9.0 before 3.9.7 from 3.10.0 before 3.10.4 Version 3.11.0 |
Weakness classification
References
- NVD record
- CVE.org record
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.4
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.1
- https://docs.github.com/en/enterprise-server@3.7/admin/release-notes#3.7.19
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.12
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.7
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.4
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.1
- https://docs.github.com/en/enterprise-server@3.7/admin/release-notes#3.7.19
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.12
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.7