critical9.8
CVE-2023-51656
Apache IoTDB: Unsafe deserialize map in Sync Tool
Impact
Deserialization of Untrusted Data vulnerability in Apache IoTDB.This issue affects Apache IoTDB: from 0.13.0 through 0.13.4. Users are recommended to upgrade to version 1.2.2, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.iotdb:iotdb-parent | >= 0.13.0, < 1.2.2 | 1.2.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Iotdb | from 0.13.0 through 0.13.4 |