high7.5
CVE-2023-51770
Arbitrary File Read Vulnerability in Apache Dolphinscheduler
Impact
Arbitrary File Read Vulnerability in Apache Dolphinscheduler. This issue affects Apache DolphinScheduler: before 3.2.1. We recommend users to upgrade Apache DolphinScheduler to version 3.2.1, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.dolphinscheduler:dolphinscheduler | < 3.2.1 | 3.2.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Dolphinscheduler | from 1.2.0 before 3.2.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- http://www.openwall.com/lists/oss-security/2024/02/20/2
- https://github.com/apache/dolphinscheduler/pull/15433
- https://lists.apache.org/thread/4t8bdjqnfhldh73gy9p0whlgvnnbtn7g
- https://lists.apache.org/thread/gpks573kn00ofxn7n9gkg6o47d03p5rw
- https://github.com/advisories/GHSA-ff2w-wm48-jhqj
- https://nvd.nist.gov/vuln/detail/CVE-2023-51770