NetSight
critical9.8

CVE-2023-51784

Apache InLong Manager Remote Code Execution vulnerability

Impact

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache InLong.This issue affects Apache InLong: from 1.5.0 through 1.9.0, which could lead to Remote Code Execution. Users are advised to upgrade to Apache InLong's 1.10.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/9329

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:manager-pojo>= 1.5.0, < 1.10.01.10.0

Affected products

VendorProductAffected versions
ApacheInlong
from 1.5.0 before 1.10.0

Weakness classification

References