NetSight
high7.5

CVE-2023-51785

Apache InLong Manager Arbitrary File Read Vulnerability

Impact

Deserialization of Untrusted Data vulnerability in Apache InLong.This issue affects Apache InLong: from 1.7.0 through 1.9.0, the attackers can make a arbitrary file read attack using mysql driver. Users are advised to upgrade to Apache InLong's 1.10.0 or cherry-pick [1] to solve it. [1]  https://github.com/apache/inlong/pull/9331

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.inlong:manager-pojo>= 1.5.0, < 1.10.01.10.0

Affected products

VendorProductAffected versions
ApacheInlong
from 1.7.0 through 1.9.0

Weakness classification

References