high7.7
CVE-2024-10975
Hashicorp Nomad Incorrect Authorization vulnerability
Impact
Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/hashicorp/nomad | <= 1.9.1 | none recorded |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Hashicorp | Nomad | from 1.3.0 before 1.7.15 from 1.3.0 before 1.9.2 from 1.8.0 before 1.8.7 from 1.9.0 before 1.9.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://discuss.hashicorp.com/t/hcsec-2024-27-nomad-vulnerable-to-cross-namespace-volume-creation-abusing-csi-write-permission
- https://github.com/advisories/GHSA-2w5v-x29g-jw7j
- https://nvd.nist.gov/vuln/detail/CVE-2024-10975
- https://github.com/hashicorp/nomad/commit/30849c518e16647a4f698e5f5cc82bef2bf40e4d